S'identifier / Créer un compte
  • Actualités
  • Dossiers
  • Tests
  • Commentaires
  • INpactiens
Publicité

Mozilla souhaite se débarrasser de Firefox 3.6, mais en douceur

Sans doute aucun salut pour les entreprises avant les versions ESR

Il n’y a qu’à observer aujourd’hui l’enchainement des versions de Firefox pour se rappeler que Mozilla a totalement changé ses méthodes de développement. Le navigateur dispose en effet d’une nouvelle version toutes les six semaines, ce qui présente des avantages et des inconvénients. Mais si l’éditeur n’oublie pas pour autant la mouture 3.6, dernière disponible avant le changement de rythme, il souhaite néanmoins s’en débarrasser.

firefox

Firefox 3.6, dernier résistant d'une autre époque

Lorsque Firefox 4.0 est sorti, Mozilla s’était longuement fait désirer. Le développement de cette version avait pris du retard (12 bêtas), même si le nombre d’améliorations était particulièrement conséquent. Peu de temps après, l’éditeur annonçait un changement radical : une nouvelle version majeure tous les trois mois, ainsi qu’un nouveau canal de diffusion baptisé Aurora, intercalé entre les Nightly (branche instable) et les bêtas. Quelques mois plus tard, Mozilla bousculait encore le calendrier : une nouvelle version toutes les six semaines.

Cet enchainement très rapide des versions a créé de nouvelles habitudes mais également une cassure fondamentale dans la gestion du support du navigateur. Depuis Firefox 4.0, la seule véritable version supportée est toujours la dernière. Quand des problèmes sont détectés, les correctifs, quels qu’ils soient, sont intégrés dans la version suivante. Exception faite des problèmes critiques de sécurité.

Mais de même que Microsoft a eu son Windows XP, Mozilla a son Firefox 3.6. Dans l’intervalle de temps entre l’apparition de ce dernier et l’arrivée de la version 4.0, la base utilisateur a eu le temps de se figer. En outre, puisque Firefox 4.0 était une branche très différente, Mozilla n’a pas souhaité forcer la mise à jour. Depuis, Firefox 3.6 est toujours supporté, et nous sommes actuellement à la mouture 3.6.24.

Inviter sans forcer

Mozilla souhaite que la branche 3.6 soit éliminée de l’équation puisque son entretien consomme évidemment des ressources. À partir du 17 novembre, le navigateur diffusera donc un message invitant les utilisateurs à télécharger la dernière version stable disponible, autrement dit Firefox 8.0. Il s’agira bien d’une invitation et non d’une obligation, l’éditeur espérant que la perspective d’une nouvelle version favorisera les migrations.

Mais Mozilla prend des pincettes pour annoncer son intention car la société précise dans la foulée qu’il ne s’agit pas d’une notification de fin de vie du produit (EOL, pour End of Life). Officiellement, Firefox 3.6 est toujours un produit en vie et il devrait donc y avoir encore plusieurs mises à jour, même si ces dernières ne corrigent que des failles de sécurité depuis un bon moment.

Une offre moins alléchante pour les entreprises

Malheureusement, si Mozilla peut espérer un retour positif de la part des particuliers, le message risque d’avoir un accueil plus frais dans les entreprises. Rappelons qu’une polémique était déjà apparue suite à l’annonce de la cassure dans le cycle de développement. Or, si les entreprises n’ont pas testé leurs applications web et autres intranets pour Firefox 8, il n’y aura pas de migration. Mozilla précise d'ailleurs que si les notifications de nouvelles versions sont désactivées, le message pour Firefox 8.0 ne sera pas affiché.

Reste à attendre que Mozilla en dise davantage sur son plan concernant le monde professionnel puisque l’éditeur compte bien mettre en place des versions plus longuement supportées et baptisées ESR, pour Extended Support Release. 
Source : Mozilla
Vincent Hermann

Rédacteur/journaliste spécialisé dans le logiciel et en particulier les systèmes d'exploitation. Ne se déplace jamais sans son épée.

Publiée le 15/11/2011 à 16:20

Soutenez l'indépendance de Next INpact en devenant Premium

  • Tout le contenu de Next INpact sans pub
  • Et bien plus encore...

Il y a 54 commentaires

Avatar de Malesendou INpactien
Malesendou Le mardi 15 novembre 2011 à 16:29:41
Inscrit le vendredi 21 mai 10 - 6045 commentaires
Il y avait de très gros changements entre la 3.x et la 4.x... Ces changements ont cassés réellement la compatibilité pour certaines extensions.

Mais désormais, la plus part ont été modifié pour fonctionner et maintenant, que ce soit la 4, la 5, la 6, la 7 et la 8, les extensions sont compatibles sans apporter une quelconque modification.
Avatar de paradise INpactien
paradise Le mardi 15 novembre 2011 à 16:31:01
Inscrit le dimanche 10 avril 05 - 14104 commentaires
J'ai encore une distro qui utilise FF 3.6 me semble-t-il...

Il faudrait que je m'en occupe, je crois que c'est une Slackware 13.1, que j'utilise de temps à autre, je vais aller voir du coup pour DL une version plus récente.
Avatar de sebtx INpactien
sebtx Le mardi 15 novembre 2011 à 16:33:01
Inscrit le mardi 8 janvier 08 - 1789 commentaires
Hum j'ai un appel à "connect.facebook.net" qui empêche le chargement correct du site, firefox reste en attente...

Du coup obligé d'ajouter "127.0.0.1 connect.facebook.net" dans mon fichier hosts.


Sinon c'est bien de se débarrasser de la 3.6, il est temps d'évoluer au niveau du web :) D'autant plus que les versions plus récentes seraient plus optimisées.

EDIT: parcontre comme ça a été souligné plus haut, ça va tellement vite que quelques distribs n'arrivent pas à suivre et surtout les modules complémentaires...

Edité par sebtx le mardi 15 novembre 2011 à 16:33
Avatar de NullPointerException INpactien
NullPointerException Le mardi 15 novembre 2011 à 16:33:40
Inscrit le mercredi 6 juillet 11 - 181 commentaires
Et hop un post inutile fais avec la version 3.6 pour pourrir les stats de pc inpact!
Un!
Avatar de Jarodd INpactien
Jarodd Le mardi 15 novembre 2011 à 16:36:01
Inscrit le mardi 26 octobre 04 - 19520 commentaires
Le problème des pros n'est pas les extensions (enfin, ça 'est plus mineur), c'est plutôt qu'il faut retester tous les process internes, et surtout que la mise à jour de xxx postes prend du temps, donc à peine une série terminée, qu'il faut déjà recommencer avec le nouvelle

L'ESR est une bonne réponse de la MoFo, maintenant il faut voir comment cela se traduit concrêtement. Le risque est que les grosses sociétés repassent à IE parce qu'au final c'est le seul navigateur qui n'a pas de nouvelle version tous les quatre matins...
Avatar de NEVdD INpactien
NEVdD Le mardi 15 novembre 2011 à 16:45:59
Inscrit le jeudi 28 août 08 - 852 commentaires
Il y avait de très gros changements entre la 3.x et la 4.x... Ces changements ont cassés réellement la compatibilité pour certaines extensions.

Mais désormais, la plus part ont été modifié pour fonctionner et maintenant, que ce soit la 4, la 5, la 6, la 7 et la 8, les extensions sont compatibles sans apporter une quelconque modification.


Google toolbar? Je vais bientot passer à Chrome, j'en ai marre d'utiliser IE pour traduire les sites de ecommerce Allemands...
Avatar de Malesendou INpactien
Malesendou Le mardi 15 novembre 2011 à 16:48:28
Inscrit le vendredi 21 mai 10 - 6045 commentaires


Google toolbar? Je vais bientot passer à Chrome, j'en ai marre d'utiliser IE pour traduire les sites de ecommerce Allemands...


Ah... les Toolbars... J'arrive même pas à croire comment on peut installer ça volontairement.
Avatar de Commentaire_supprime INpactien
Commentaire_supprime Le mardi 15 novembre 2011 à 16:48:36
Inscrit le vendredi 31 octobre 08 - 27113 commentaires
Le problème des pros n'est pas les extensions (enfin, ça 'est plus mineur), c'est plutôt qu'il faut retester tous les process internes, et surtout que la mise à jour de xxx postes prend du temps, donc à peine une série terminée, qu'il faut déjà recommencer avec le nouvelle

L'ESR est une bonne réponse de la MoFo, maintenant il faut voir comment cela se traduit concrêtement. Le risque est que les grosses sociétés repassent à IE parce qu'au final c'est le seul navigateur qui n'a pas de nouvelle version tous les quatre matins...


+1 pour l'ESR. On pourra peut-être avoir un support façon LTS d'Ubuntu pour Firefox (genre : une nouvelle version tous les deux ans, supportée pendant 3 ou 5 ans au niveau des correctifs).
Avatar de paradise INpactien
paradise Le mardi 15 novembre 2011 à 16:53:50
Inscrit le dimanche 10 avril 05 - 14104 commentaires
Il est vrazi que ça défile, les versions de Firefox !

Sur ma Mandriva, j'en suis déjà à la version 8.0 (kernel MIB 3.0.8) !
Avatar de paradise INpactien
paradise Le mardi 15 novembre 2011 à 17:00:24
Inscrit le dimanche 10 avril 05 - 14104 commentaires


Ah... les Toolbars... J'arrive même pas à croire comment on peut installer ça volontairement.



Une copine en a une tonne sur son Seven, je l'ai proprement engueulé, elle ramasse plein de saloperies au passage.

Passage au Kärcher de son Seven, UAC, je lui ai installé Chromium (pas Chrome) pour lui montrer un navigateur simple et non surchargé, vu l'utilisation qu'elle avait de IE (pas la faute vraiment à IE, mais à elle-même, on est d'accord).

Firefox aurait pu convenir, Chromium devrait lui convenir mieux encore.


Edité par paradise le mardi 15 novembre 2011 à 17:01
;