S'identifier / Créer un compte
  • Actualités
  • Dossiers
  • Tests
  • Commentaires
  • INpactiens
Publicité

Mac OS X Lion n'intègre plus la couche d'émulation Rosetta

Faites l'inventaire de vos applications avant de migrer

En 2006, le passage d’Apple à Intel crée la surprise. L’abandon de l’architecture PowerPC a eu de nombreuses conséquences dont une très importante : les applications ne pouvaient plus fonctionner sur les nouvelles machines Intel, car il fallait que le code soit compilé pour x86. Mais Apple avait dans la foulée présenté Rosetta, une couche d’émulation permettant de faire fonctionner de manière transparente les applications PowerPC, au prix d’une chute des performances. Mais Rosetta n’est pas présente dans Lion.

rosetta

Dans un mois, votre achat éventuel de Lion devra tenir compte de la disparition de Rosetta. Cette couche d’émulation est dans Mac OS X depuis la version Intel de Tiger, et donc Leopard et Snow Leopard. S’il vous reste des applications PowerPC comme Office 2004, il va donc falloir préparer la migration.

Il n’existe pas réellement de solution miracle. Vous avez trois possibilités :
  • Vous procurer des versions plus récentes des applications qui seront forcément compilées pour Intel, mais qui vous obligera certainement à repasser à la caisse. Dans le cas de gros logiciels tels que Photoshop, ce ne sera pas si évident.
  • Installer Lion dans une autre partition, pour avoir les deux systèmes en parallèle et ne garder par exemple l’ancien que pour les applications PowerPC
  • Repousser l’achat de Lion
Rappelons que ce dernier ne pourra de toute façon s’installer que sur des Mac relativement récents : on ne peut l’acheter que depuis Snow Leopard dans le Mac App Store.
 
Source : MacRumors
Vincent Hermann

Rédacteur/journaliste spécialisé dans le logiciel et en particulier les systèmes d'exploitation. Ne se déplace jamais sans son épée.

Publiée le 15/06/2011 à 08:59

Soutenez l'indépendance de Next INpact en devenant Premium

  • Tout le contenu de Next INpact sans pub
  • Et bien plus encore...

Il y a 104 commentaires

Avatar de mrfred INpactien
mrfred Le mercredi 15 juin 2011 à 09:40:39
Inscrit le jeudi 1 septembre 05 - 2017 commentaires
Pour certains gamers, ça va être très problèmatique, vu qu'à cause du retrait de Rosetta, on ne pourra plus jouer à Starcraft ou Diablo 2 sous Mac OS X

Bon, en même temps, je suppose que ça doit bien tourner avec Wine ou Corssweaver, vu que ça fonctionne sans problèmes sous Linux (et comme Mac OS X est un Unix compatible POSIX).


J'ai immédiatement pensé à ça en plus.
Avatar de wrinkly INpactien
wrinkly Le mercredi 15 juin 2011 à 09:40:53
Inscrit le mercredi 15 juin 11 - 2 commentaires
Pour certains gamers, ça va être très problèmatique, vu qu'à cause du retrait de Rosetta, on ne pourra plus jouer à Starcraft ou Diablo 2 sous Mac OS X

Bon, en même temps, je suppose que ça doit bien tourner avec Wine ou Corssweaver, vu que ça fonctionne sans problèmes sous Linux (et comme Mac OS X est un Unix compatible POSIX).


Il me semble que si tu as la clé d'activation, tu peux télécharger une version compatible sur le site de blizzard.
Avatar de vida18 INpactien
vida18 Le mercredi 15 juin 2011 à 09:42:47
Inscrit le jeudi 17 avril 08 - 995 commentaires
Jaskier a écrit :

Bon, en même temps, je suppose que ça doit bien tourner avec Wine ou Corssweaver, vu que ça fonctionne sans problèmes sous Linux (et comme Mac OS X est un Unix compatible POSIX).


Il y a aussi TransGaming's Cider.
Avatar de Vincent_H Equipe
Vincent_H Le mercredi 15 juin 2011 à 09:42:47
Inscrit le jeudi 30 janvier 03 - 15417 commentaires

Il me semble que si tu as la clé d'activation, tu peux télécharger une version compatible sur le site de blizzard.


Oui mais ces deux jeux réclament effectivement la présence de Rosetta.
Avatar de wrinkly INpactien
wrinkly Le mercredi 15 juin 2011 à 09:48:22
Inscrit le mercredi 15 juin 11 - 2 commentaires

Oui mais ces deux jeux réclament effectivement la présence de Rosetta.


Je dois confondre avec un truc encore plus vieux , mes CD de Diablo II demandaient mac os classic et j'avais dû dl des versions mac os x depuis battle.net.
Avatar de kobal INpactien
kobal Le mercredi 15 juin 2011 à 09:54:59
Inscrit le mercredi 26 septembre 07 - 212 commentaires
Voilà une news qui illustre à la perfection les propos de R. Stallman publiés dernièrement sur les logiciels "privateurs"...
Avatar de sashimi INpactien
sashimi Le mercredi 15 juin 2011 à 09:55:15
Inscrit le vendredi 3 avril 09 - 472 commentaires
2 partitions avec 2 versions d'OSX différentes ou virtualiser une ancienne version d'OSX, ou utiliser wine ou un crossover du genre...

Qu'on vienne encore me soutenir que Mac & OSX, c'est tellement plus simple d'utilisation que les OS concurrents...

N'empêche que, les utilisateurs d'OS concurrents, eux, finissent par se casser le cul à mettre en oeuvre ce genre de solution lourdingue. Un Macqueux moyen, pseudo-geek qui n'y comprend rien en technique, lui, rentra gentiment sans faire de vague dans le rang et ira acheter son update de photoshop à xK€. (peut-être un vague "mais-euh..." couinant, suivi d'une parole dogmatique "Raquer tu devras, it's so much more brilliantly awesome" de Jobs, et la protestation se taiera)

Edité par sashimi le mercredi 15 juin 2011 à 09:59
Avatar de calorifuge INpactien
calorifuge Le mercredi 15 juin 2011 à 09:56:50
Inscrit le mercredi 9 février 05 - 128 commentaires
Il n'y a rien d'indispensable avec Lion et en plus de ça je vais devoir dire adieu à quelques petits émulateurs et quelques vieux jeux sniff..Pour une fois je crois que vais attendre avant de faire cette màj ( et peu être me racheter un pc... ).
Avatar de Groumfy INpactien
Groumfy Le mercredi 15 juin 2011 à 10:00:09
Inscrit le mercredi 8 décembre 04 - 3114 commentaires

Je dois confondre avec un truc encore plus vieux , mes CD de Diablo II demandaient mac os classic et j'avais dû dl des versions mac os x depuis battle.net.


De toute façon, c'est la faute de Blibli qui n'a toujours pas sorti Diablo 3.
En plus, ça coùte moins cher d'acheter la nouvelle version Diablo que la nouvelle version de Photoshop !
;